SSH-KEYSIGN(8) BSD System Manager's Manual SSH-KEYSIGN(8)
ssh-keysign - ssh helper program for hostbased authentication
ssh-keysign is used by ssh(1) to access the local host keys and generate
the digital signature required during hostbased authentication with SSH
protocol version 2.
ssh-keysign is disabled by default and can only be enabled in the the
global client configuration file /etc/ssh/ssh_config by setting
HostbasedAuthentication to ``yes''.
ssh-keysign is not intended to be invoked by the user, but from ssh(1).
See ssh(1) and sshd(8) for more information about hostbased authentica-
Controls whether ssh-keysign is enabled.
These files contain the private parts of the host keys used to
generate the digital signature. They should be owned by root,
readable only by root, and not accessible to others. Since they
are readable only by root, ssh-keysign must be set-uid root if
hostbased authentication is used.
ssh(1), ssh-keygen(1), ssh_config(5), sshd(8)
Markus Friedl <firstname.lastname@example.org>
ssh-keysign first appeared in OpenBSD 3.2.
BSD May 24, 2002 BSD